BGP JUNE 2023

BGP

- It is an application layer protocol (layer  7 protocol).

- It works on TCP port number 179.

       In order to check above statement:

       #show tcp brief

       #debug ip tcp transaction

- TCP protocol No is 6.

- It is used for policy based routing(PBR).

- BGP does not support broadcast & multicast.
- BGP only works with unicast.

TYPES OF TABLE IN BGP

1. BGP Table

    #Show ip bgp


2. Neighbour Table

    #show ip bgp neighbor

     #show ip bgp summary

3. Routing Table

    #show ip route bgp 

TYPES OF NEIGHBOUR

1 IBGP: 

Neighbour can be directly connected or can not be directly connected

EBGP: 

Neighbour must be directly connected.

Neighbour can be directly connected or can not be directly connected

BGP NEIGHBOUR ADGNECY

* Predefined neighbour ip must be same.

*Predefined neighbour ASN must be same.

BGP neighbour syntax

R#conf t

R#router bgp [ local ASN] 

R#neighbour [remote ip] remote-as [neighbour ASN]


BGP UPDATE-SOURCE

In order to build neighbourship with indirectly connected network we need "update-source interface command.
R#router bgp 12

R#neighbour 2.2.2.2 update-source int g0/1


BGP EBGP-MULTIHOP

THIS COMMAND IS USED TO INCREASE THE TTL VALUE WHILE SENDING THE ECHO REQUEST

In order to build neighbourship with indirectly connected network with ebgp router it sends TTL value 1 so it is dropped after one interface 1-0=0 and when router interface counters packet with TTL value 0 it drops the packet instantly. so in order to avoid this admin should use command 

"EBGP-MULTIHOP [the number of hop interface packet has to pass through]"..


R#router bgp 12

R#neighbour 2.2.2.2 update-source int g0/1

R#neighbour 22 ebgp-multiplehop 2

Adminstrative distance for BGP

1. AD for IBGP is 200

2. AD for IBGP is 20

IBGP SPLIT HORIZON 
By default route reflector is enabled in bgp router once we make route-reflector other neighbour of the route-reflector become route-reflector client.
BGP AUTHENTICATION
R# conf t
R# router bgp [ASN]
R# neighbor [ip address] password [ncp]
* MD5 digest(message digest type 5) is used by default.
BGP PATH SECLECTION
1. If next hop is inaccessible packet update will be drop.
2. Prefer the path with highest weight.
3. If the weight are same prefer path with the highest LOCAL PREFERENCE.
4. If LP are same. prefer the path with that was originated by bgp router i.e next hop= 0.0.0.0.
5. If no route was originated prefer the route that shortest AS-path 
6. If all path have same AS path length prefer the path with lowest origin code(i<e<?).
7. If the origin codes are the same prefer the path the lowest MED(Multi-Exit Discriminator).
8. If the path have same MED Prefer external path over internal path..
9. For IBGP path, Closest IBGP.
10. For EBGP path oldest (stable). 
11. Prefer path with lowest neighbour bgp router ID.
12. Prefer the path with lowest neighbour ip address..

BGP TRAFFIC POLICY
    OUTGOING TRAFFIC POLICY
        Weight & LP(LOCAL PREFERENCE)
Weight 
Weight only works with cisco.
16 bits.
Range (0-65535).
Locally generated NID => weight 32768.
weight local to the router.
weight for IBGP = 0 (ZERO).
weight for EBGP = 0 (ZERO).
Highest wieght will be prefered.
we can change outgoing traffic policy of a single router.
weight can directly apply on neighbour.
Weight can be applied with ACL & ROUTE-MAP.
Weight will apply in inbound direction.

 LP(LOCAL PREFERENCE) OUTGOING TRAFFIC POLICY
32 bits
Local to ASN
We can change the outgoing traffic policy of entire AS
we can apply LP using "inbound" ACL & route-map


INCOMING TRAFFIC POLICY IN BGP
    1. AS PATH PREPENDING
    2. METRIC

AS PATH PREPENDING.
Using this method we can change the path of the traffic coming from the another AS to our own AS
we can use these command to implement AS PATH PREPENDING method.
COMMANDS
R#CONF T
R#ACCESS-LIST 10 PERMIT 11.11.11.0 0.0.0.255
R#ROUTE-MAP ASPATH PERMIT 1
R#MATCH IP ADDRESS 10
R#SET AS-PATH PREPENDING 100 200
R#ROUTE-MAP ASPATH PERMIT 2
R#EXIT

R#ROUTER BGP 12
R#NEIGHBOR 13.1.1.1 ROUTE-MAP ASPATH OUT

METRIC.
To change the traffic policy we can also use the metric we can use these command to implement METRIC method.
COMMANDS
R#CONF T
R#ACCESS-LIST 10 PERMIT 11.11.11.0 0.0.0.255
R#ROUTE-MAP metric PERMIT 1
R#MATCH IP ADDRESS 10
R#SET weight 50
R#ROUTE-MAP metric 2
R#EXIT

R#ROUTER BGP 12
R#NEIGHBOR 13.1.1.1 ROUTE-MAP metric OUT


AS PATH PREPENDING:- we can change incoming Traffic policy of directly connected or non directly connected ASN.

Metric:- we can change incoming Traffic policy of directly connected ASN only


BGP ADVERTISEMENT TIMER

1. HOW TO CHANGE IBGP ADVERTISEMENT INTERVAL?
ANS: 
R#conf t
R#router bgp 12
R#neighbor 12.1.1.1 advertisement-interval 45
2. HOW TO CHANGE EBGP ADVERTISEMENT INTERVAL?
ANS: 
R#conf t
R#router bgp 12
R#neighbor 24.1.1.4 advertisement-interval 45

BGP AGGREGATE
BGP CONFEDERATION
  • Divide Public ASN or Global ASN into multiple ASN Private ASN.
  • BGP confederation is used to reduce multiple TCP session. 
IBGP-PEER GROUP
We can reduce No. of command required for R2 to communicate & manage between R3,R4 & R5.
How to implement IBGP_PEER PEER-GROUP?
ANS: 
R# conf t
R# router bgp [ASN]
R# neighbor IBGP_PEER peer-group
R# neighbor IBGP_PEER remote-as 200
R# neighbor IBGP_PEER password ncp@123
R# neighbor IBGP_PEER update-source Loopback0
R# neighbor IBGP_PEER next-hop-self
R# neighbor IBGP_PEER distribute-list 10 out
R# neighbor 3.3.3.3 peer-group IBGP_PEER
R# neighbor 4.4.4.4 peer-group IBGP_PEER
R# neighbor 5.5.5.5 peer-group IBGP_PEER

BGP 4 Byte ASN
By default 2 byte is configured but due to population increase & demand for more ASN we need 4 byte ASN
1. ASPLAIN :- It simple notation 2 bytes only.
1. ASDOT    : - It only works with A.B asn it does not support both unlike ASDOT+
2. ASDOT+ :-   It does support both A.B and traditional also.

IBGP SYNCHRONIZATION RULE
* By default this rule is disabled
* NID Received from IBGP will be marked with > sign till same route will not receive from any IGP       Protocols.
BGP ROUTER STATES
 IDLE STATE
 CONNECT STATE    ACTIVE
 OPEN SENT              OPEN CONFIRM
 ESTABLISHED

By default in bgp Router are follow these flow
IDLE STATE ->  CONNECT STATE  -> OPEN SENT -> OPEN CONFIRM -> ESTABLISHED

BGP MESSEGE

OK                                                                                       NOT                                    UPDATE
|                                                                                                                                             |
|-Open sent            Keepalive(60 second)                        Notice                                    |Update
|                               if 3 keepalive message missed          Router receives notice     |  
|                               then neighbourship breaks.                Password mismatch, Worng AS            |Withdrawn
|-Open confirm



ORIGINATOR ID   &    CLUSTER ID
    ORIGINATOR ID:- Router ID's of the router who originated the route. Router id of route reflector                                                                                   client
    
    CLUSTER ID      :- Router ID's of the route-reflector.

VIRTUAL PRIVATE NETWORK ( VPN )

|     SITE 1  | ---------VPN------|     SITE 2    |
 Private NID                                 Private NID

1. Peer to peer model
        Connectivity issues     }
        Routing issues             }           ISP WILL HANDLE BOTH
Example of peer to peer model 
                            MPLS
        
2. Overlay model
        Connectivity issues  }              ISP WILL HANDLE ONLY CONNECTIVITY ISSUE
        Routing issues          }              CLIENT WILL HANDLE ROUTING ISSUE
Example of peer to peer model 
                            GRE, DMVPN,SDWAN

GRE (Generic Routing Encapsulation)
* By default enabled on tunnel interface
* Tunnel int is a logical int & by default up.
* GRE provides virtual end-to-end tunnel
GRE has some prerequisite.
1. Tunnel interface
2. Tunnel ip address : it should be private ip address
3. Tunnel source     : it must be public static ip address
4. Tunnel destination: it must be public static ip address



                

===================******===================*****=========================

1
www.ncpnetwork.com | www.ncpnuggets.in info@ncpnetwork.com
+919871 48 1152 | +919910 111 641 
Syllabus CCNP Enterprises 
Network Terminology
• Route Selection Component
• LM
• AD
• METRIC
• Route Tagging
• Route filtering 
• Route Poisson
• Auto Summary
• Manual Summary
• PBR
• VRF
• BFD
EIGRP
• Eigrp Introduction 
• EIGRP Implementation
• Types of Eigrp Tables
• Neighbor Adjacency Component
• Eigrp Neighbor Table Explain
• Eigrp packet capture with Wireshark
• Eigrp authentication & Verification with Wireshark
• Eigrp Auto-Summary
• Eigrp Manual summary
• Eigrp no-summary
2
• DUAL & Its Component
• Successor, feasible successor, RD and, AD
• Load distribution on un-equal path via Variance Factor
• Route filtering via ACL & Distribute List ( inbound and outbound)
• Route filtering via Prefix-list (Inbound and Outbound)
• Eigrp Internal Default Route
• Eigrp external Default Route
• Eigrp Split-Horizon
• Eigrp unicast behavior 
• Route Tagging & Filtering with route_map
• EIGRP route poison
• SIA (Stuck in Active)
• SIA Quarry, SIA Reply
• Eigrp STUB Feature
• Eigrp Address Family
• Named Eigrp
OSPF
• OSPF Introduction
• OSPF Implementation
• OSPF Metric type 1 & type 2 Modification & Verification
• OSPF Cost Calculation 
• OSPF Neighbor Adjacency Component.
• Types of OSPF Network
✓ point to point 
✓ point to multipoint
✓ BMA & NBMA
• OSPF Authentication and Verification with Wireshark
• Hello and Dead Timer Mismatch
OSPF AREA Types
✓ Normal
✓ STUB
✓ NSSA
• Types of OSPF Routers
• Internal, External, Backbone, ABR, ASBR, DR, BDR
• Election Process of DR & BDR
3
• Function of wait timer in DR & BDR
• Summarization and ABR / ASBR
• OSPF Redistribution 
• OSPF Database
• LSA TYPE-1, LSA-2 , LSA-3, LSA-4, LSA-5, LSA-6, LSA-7
• AGE, SEQ NO. LINK Count.
• LSA Refresh Timer
• STUB Area, Totally Stub Area, NSSA, Totally NSSA
• OSPF Default Route in normal Area
• OSPF Default Route in NSSA
• NSSA will not allow LSA Type 5
• OSPF Path Preference
✓ O vs OIA
✓ OE1 vs OE2
✓ OE2 vs ON2
✓ OIA vs ON2
• OSPF Loopback as a host Route
• OSPF Virtual- link
• Route filtering 
• ACL & Distribute-list
• Prefix & Distribute-list
• OSPF Packet Types Verification with Wireshark
• OSPF Route State Verification with Wireshark & Debug
BGP
• BGP Introduction
• Protocol & Port no.
• Types of BGP Table
• Types of ASN
✓ Public ASN
✓ Private ASN
• BGP 2Byte ASN
• BGP 4 Byte ASN
• Types of Neighbor
• IBGP Peer
• EBGP Peer
4
• BGP Neighbor Adjacency Component
• When BGP Neighbor will not form
• Explain of “show ip bgp summary”
• Verification of TCP Connection
• Explain “show ip BGP”
• IBGP & EBGP Peer on common subnet 
• Concept of update source loopback
• Concept of EBGP Multiple hop
• Concept of TTL Modification IBGP & EBGP
• Next hop will change in EBGP
• BGP Authentication 
• Next hop self
• IBGP Synchronization rule 
• IBGP loop prevention technique
• IBGP Split-horizon rule
• Route-reflector–client
• Originator ID
• Cluster ID
• BGP Route filtering 
• BGP path selection order
• BGP Traffic Policy
✓ Incoming traffic policy
✓ Outgoing traffic policy
• Verification of default outgoing path
• Modification of outgoing path via Weight & Attributes
• use of ACL / Prefix & Route-map
• Modification of outgoing path via LP
• Verification of default incoming path
• Modification of Incoming traffic via AS-PATH PREPEND 
• Modification of Incoming traffic via MED
• BGP Golden Rule
• Difference between metric & as-path prepending
• BGP Peering
• BGP Advertisement timer
• BGP scan timer
• BGP Message verification via wireshark & debug
5
• TCP session/BGP session Tracking of Neighbor 
• BGP Confederation
• Remote private ASN
• EBGP Loop prevention Technique
• BGP route-refresh 
• BGP Aggregate
• BGP Route-State
• BGP State
• BGP Dynamic peer
• BGP Address family
DMVPN
• MGRE
• NHRP
• NHRP Registration & Reply
• Under lay & over lay Network
• NHRP Server & Client
SECURITY
• UPRF
• UPRF Mode
✓ stick mode
✓ loose Mode
• Control Plain Policy
• Telnet
• SSH
• SNMP
• EIGRP
• OSPF
• BGP
IPV4 Access-list
• Standard
• Extended
• Time-based
IPV6 Traffic Filter
6
AAA
• Radius vs Tacacs+
• AAA Configuration
• IPV6 First hop Security
IPV6
• Ipv6 Introduction
• IPv6 Rules
• Types of IPv6 Address
• IPv6 Host Bits and Network bits
• IPv6 EUI-64
• IPv6 address Implementation and Verification
• IPv6 OSPF V3
• IPv6 EIGRP v6
• IPv6 BGP
• IPv6 Static Route
• IPv6 RIP
• IPv6 Protocol Redistribution 
VPN
VPN Introduction
VPN Model
Classification of VPN
VPN Terminology (GRE)
GRE
Drawback of GRE
VRF
VRF Implementation (static)
VRF Lite
MPLS Introduction
MPLS Architecture
Control Plain and Data plain
LDP lable allocation & Distribution
LDP label operation (push, swap, pop)
7
IPSEC VPN
• Encapsulation
• encryption
• Hashing 
• DH GROUP
SERVICES
• syslog server
• Types of syslog server
• consol login
• Terminal login
• syslog server login (external server)
• syslog severity level
IPv6 DHCP Server
• client
• Relay agent
• packet
SCP (Secure copy)
SNMP
SNMP Message
SNMPv3 Authentication
SNMPv3 Configuration
PBR + IPSLA
Net-flow
Device Management
Address Family
• EIGRP with Named
• EIGRP with address family IPv4
• EIGRP with address family IPv6
• OSPF with address family IPv4
• OSPF with address family IPv6
• BGP with address family IPv4
• BGP with address family IPV6




Comments

Popular posts from this blog

Basic C Language | A 2 Z | SRC | LEARN C FROM BASICS |

SUBNETTING PRATICE DECEMBER 2022

Syllabus for mpls